// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*?\bRationale-|Normal|List Paragraph\t(?:\d+\)[ \t]*)?)[ \t]*").unwrap();
let string = "List Paragraph 36) Rationale-1 - Details on the context:
List Paragraph 37) None.
Normal
List Paragraph 38) 2 - Statement complements:
List Paragraph 39) Blablablabla
List Paragraph (1) Blablablabla
List Paragraph (2) Blablablabla
List Paragraph (3) Blablablabla
List Paragraph (4) Blablablabla
List Paragraph (5) Blablablabla
List Paragraph (6) Blablablabla
List Paragraph (7) Blablablabla
Normal
List Paragraph 40) Blablablabla
Normal
List Paragraph 41) 3 - Statement justification:
List Paragraph 42) Blablablabla
Normal
List Paragraph 43) Blablablabla
List Paragraph 44) Blablablabla
List Paragraph 45) Blablablabla
List Paragraph 46) Attached Files: Rationale-
Normal";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}