import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/([a-z]{2})\\/[a-z]{2}-\\1\\/coolapp(?:\\/.*)?";
final String string = "/us/en-us/coolapp\n"
+ "/us/en-us/coolapp/faq\n"
+ "/us/en-us/coolapp/privacy-policy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}