$re = '/\/([a-z]{2})\/[a-z]{2}-\1\/coolapp(?:\/.*)?/m';
$str = '/us/en-us/coolapp
/us/en-us/coolapp/faq
/us/en-us/coolapp/privacy-policy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);