using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"has completed in (?P<seconds>[\d\.]*) seconds";
string input = @"has completed in 7878.666 seconds";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}