package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)has completed in (?P<seconds>[\d\.]*) seconds`)
var str = `has completed in 7878.666 seconds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}