use strict;
my $str = 'Plop
```
<p>```
~~~
<p>```
```
Some *markdown*
```
<div>
<html>
```
```
function test();
```
<div markdown="1">
```
<p>```
~~~
<p>```
```
```
<p>```
~~~
<p>```
```
~~~
<p>```
```
<p>```
~~~
';
my $regex = qr/(?:(?<=\n)|(?<=\A)) # Necessarily at the begining of a new line or start of string
(?<code_all>
(?<code_start>
[ ]{0,3} # Possibly up to 3 leading spaces
\`{3,} # 3 code marks (backticks) or more
)
\n+
(?<code_content>.*?) # enclosed content
\n+
(?<!`)
\g{code_start} # balanced closing block marks
(?!`)
[ \t]* # possibly followed by some space
\n
)/mxsp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}