$re = '/(?:(?<=\n)|(?<=\A)) # Necessarily at the begining of a new line or start of string
(?<code_all>
(?<code_start>
[ ]{0,3} # Possibly up to 3 leading spaces
\`{3,} # 3 code marks (backticks) or more
)
\n+
(?<code_content>.*?) # enclosed content
\n+
(?<!`)
\g{code_start} # balanced closing block marks
(?!`)
[ \t]* # possibly followed by some space
\n
)/mxs';
$str = 'Plop
```
<p>```
~~~
<p>```
```
Some *markdown*
```
<div>
<html>
```
```
function test();
```
<div markdown="1">
```
<p>```
~~~
<p>```
```
```
<p>```
~~~
<p>```
```
~~~
<p>```
```
<p>```
~~~
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);