package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((\w+)\((,?\s*-?\d*\.?\d+(px|in|px|cm|mm|pt|pc|em|ex|ch|rem|deg|rad|grad|turn)?)+\)\s*)`)
var str = `rotate(120deg,1212,813)
px|in|px|cm|mm|pt|pc|em|ex|ch|rem|deg|rad|grad|turn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}