$re = '/((\w+)\((,?\s*-?\d*\.?\d+(px|in|px|cm|mm|pt|pc|em|ex|ch|rem|deg|rad|grad|turn)?)+\)\s*)/i';
$str = 'rotate(120deg,1212,813)
px|in|px|cm|mm|pt|pc|em|ex|ch|rem|deg|rad|grad|turn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);