#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^[^,]*, |\G(?!^) AND )\K.+?(?= AND |$)"
Local $sString = "NETHERLANDS (THE)" & @CRLF & _
"BOLIVIA (PLURINATIONAL STATE OF)" & @CRLF & _
"COCOS (KEELING) ISLANDS (THE)" & @CRLF & _
"ANTIGUA AND BARBUDA" & @CRLF & _
"" & @CRLF & _
"TEST1, SOME TEXT" & @CRLF & _
"TEST2, SAINT HELENA AND ASCENSION AND TRISTAN DA CUNHA" & @CRLF & _
"TEST3, BONAIRE AND SINT EUSTATIUS AND SABA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")