re = /(?:^[^,]*, |\G(?!^) AND )\K.+?(?= AND |$)/m
str = 'NETHERLANDS (THE)
BOLIVIA (PLURINATIONAL STATE OF)
COCOS (KEELING) ISLANDS (THE)
ANTIGUA AND BARBUDA
TEST1, SOME TEXT
TEST2, SAINT HELENA AND ASCENSION AND TRISTAN DA CUNHA
TEST3, BONAIRE AND SINT EUSTATIUS AND SABA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end