using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"title=\""([^\""]*)\""";
string input = @"<a href=""http://google.com/"" target=""_self"" title=""TEXTDATA"" class=""encyclopedia"">Google</a>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}