package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)title=\"([^\"]*)\"`)
var str = `<a href="http://google.com/" target="_self" title="TEXTDATA" class="encyclopedia">Google</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}