import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4})(?:.*?((?:[2-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?|1 hour(?: 30 minutes)?|30 minutes))?";
final String string = "Pay for zone 1234 for 1 hour\n"
+ "Pay for zone 4567\n"
+ "Pay for zone 1234 for 1 hour 30 minutes";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}