$re = '/(\d{4})(?:.*?((?:[2-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?|1 hour(?: 30 minutes)?|30 minutes))?/u';
$str = 'Pay for zone 1234 for 1 hour
Pay for zone 4567
Pay for zone 1234 for 1 hour 30 minutes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);