#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/.{1,}:.+|^Null|^VLAN)"
Local $sString = "GigaEthernet0/5" & @CRLF & _
"GigaEthernet0/6" & @CRLF & _
"GigaEthernet0/45" & @CRLF & _
"GigaEthernet0/3" & @CRLF & _
"GigaEthernet0/1" & @CRLF & _
"GigaEthernet0/2" & @CRLF & _
"VLAN10" & @CRLF & _
"EPON110/111" & @CRLF & _
"EPON0/2" & @CRLF & _
"EPON0/3" & @CRLF & _
"EPON0/4" & @CRLF & _
"EPON0/1:1" & @CRLF & _
"EPON0/10:2" & @CRLF & _
"EPON0/20:3" & @CRLF & _
"EPON0/1:4" & @CRLF & _
"EPON0/1:5" & @CRLF & _
"EPON0/1:6" & @CRLF & _
"EPON0/1:7" & @CRLF & _
"EPON0/111:8" & @CRLF & _
"EPON0/1:9" & @CRLF & _
"EPON0/1:10" & @CRLF & _
"EPON0/1:11" & @CRLF & _
"EPON0/1:12" & @CRLF & _
"EPON0/1:13" & @CRLF & _
"EPON0/1:14" & @CRLF & _
"EPON0/1:15" & @CRLF & _
"EPON0/1:16" & @CRLF & _
"EPON0/1:17" & @CRLF & _
"EPON0/1:18" & @CRLF & _
"EPON0/1:19" & @CRLF & _
"EPON0/1:20" & @CRLF & _
"EPON0/1:21" & @CRLF & _
"EPON0/1:22" & @CRLF & _
"EPON0/1:23" & @CRLF & _
"EPON0/1:24" & @CRLF & _
"EPON0/1:25" & @CRLF & _
"EPON0/1:26" & @CRLF & _
"EPON0/1:27" & @CRLF & _
"EPON0/1:28" & @CRLF & _
"EPON0/1:29" & @CRLF & _
"EPON0/1:30" & @CRLF & _
"EPON0/1:31" & @CRLF & _
"EPON0/1:32" & @CRLF & _
"EPON0/1:33" & @CRLF & _
"EPON0/1:34" & @CRLF & _
"EPON0/1:35" & @CRLF & _
"EPON0/1:36" & @CRLF & _
"EPON0/1:37" & @CRLF & _
"EPON0/1:38" & @CRLF & _
"EPON0/1:39" & @CRLF & _
"EPON0/1:40" & @CRLF & _
"EPON0/1:41" & @CRLF & _
"EPON0/1:42" & @CRLF & _
"EPON0/2:1" & @CRLF & _
"EPON0/2:2" & @CRLF & _
"EPON0/2:3" & @CRLF & _
"EPON0/2:4" & @CRLF & _
"EPON0/2:5" & @CRLF & _
"EPON0/2:6" & @CRLF & _
"EPON0/2:7" & @CRLF & _
"EPON0/2:8" & @CRLF & _
"EPON0/2:9" & @CRLF & _
"EPON0/2:10" & @CRLF & _
"EPON0/2:11" & @CRLF & _
"EPON0/2:12" & @CRLF & _
"EPON0/2:13" & @CRLF & _
"EPON0/2:14" & @CRLF & _
"EPON0/2:15" & @CRLF & _
"EPON0/2:16" & @CRLF & _
"EPON0/2:17" & @CRLF & _
"EPON0/2:18" & @CRLF & _
"EPON0/2:19" & @CRLF & _
"EPON0/2:20" & @CRLF & _
"EPON0/2:21" & @CRLF & _
"EPON0/3:1" & @CRLF & _
"EPON0/3:2" & @CRLF & _
"EPON0/3:3" & @CRLF & _
"EPON0/3:4" & @CRLF & _
"EPON0/3:5" & @CRLF & _
"EPON0/3:6" & @CRLF & _
"EPON0/3:7" & @CRLF & _
"EPON0/3:8" & @CRLF & _
"EPON0/3:9" & @CRLF & _
"EPON0/3:10" & @CRLF & _
"EPON0/3:11" & @CRLF & _
"EPON0/3:12" & @CRLF & _
"EPON0/3:13" & @CRLF & _
"EPON0/3:14" & @CRLF & _
"EPON0/3:15" & @CRLF & _
"EPON0/3:16" & @CRLF & _
"EPON0/3:17" & @CRLF & _
"EPON0/3:18" & @CRLF & _
"EPON0/3:19" & @CRLF & _
"EPON0/3:20" & @CRLF & _
"EPON0/3:21" & @CRLF & _
"EPON0/3:22" & @CRLF & _
"EPON0/3:23" & @CRLF & _
"EPON0/3:24" & @CRLF & _
"EPON0/3:27" & @CRLF & _
"EPON0/3:28" & @CRLF & _
"EPON0/3:29" & @CRLF & _
"EPON0/3:64" & @CRLF & _
"EPON0/4:1" & @CRLF & _
"EPON0/4:2" & @CRLF & _
"EPON0/4:3" & @CRLF & _
"EPON0/4:4" & @CRLF & _
"EPON0/4:5" & @CRLF & _
"EPON0/4:6" & @CRLF & _
"EPON0/4:7" & @CRLF & _
"EPON0/4:8" & @CRLF & _
"EPON0/4:9" & @CRLF & _
"EPON0/4:10" & @CRLF & _
"EPON0/4:11" & @CRLF & _
"EPON0/4:12" & @CRLF & _
"EPON0/4:13" & @CRLF & _
"EPON0/4:14" & @CRLF & _
"EPON0/4:15" & @CRLF & _
"EPON0/4:16" & @CRLF & _
"EPON0/4:17" & @CRLF & _
"EPON0/4:18" & @CRLF & _
"EPON0/4:19" & @CRLF & _
"EPON0/4:20" & @CRLF & _
"EPON0/4:21" & @CRLF & _
"EPON0/4:22" & @CRLF & _
"EPON0/4:23" & @CRLF & _
"EPON0/4:24" & @CRLF & _
"EPON0/4:25" & @CRLF & _
"EPON0/4:26" & @CRLF & _
"EPON0/4:27" & @CRLF & _
"EPON0/4:28" & @CRLF & _
"EPON0/4:29" & @CRLF & _
"EPON0/4:30" & @CRLF & _
"EPON0/4:31" & @CRLF & _
"EPON0/4:32" & @CRLF & _
"EPON0/4:33" & @CRLF & _
"EPON0/4:34" & @CRLF & _
"EPON0/4:35" & @CRLF & _
"EPON0/4:36" & @CRLF & _
"EPON0/4:37" & @CRLF & _
"EPON0/4:38" & @CRLF & _
"EPON0/4:39" & @CRLF & _
"EPON0/4:40" & @CRLF & _
"EPON0/4:41" & @CRLF & _
"EPON0/4:42" & @CRLF & _
"EPON0/4:43" & @CRLF & _
"EPON0/4:44" & @CRLF & _
"EPON0/4:45" & @CRLF & _
"EPON0/4:46" & @CRLF & _
"EPON0/4:47" & @CRLF & _
"EPON0/4:48" & @CRLF & _
"EPON0/4:49" & @CRLF & _
"EPON0/4:50" & @CRLF & _
"EPON0/4:51" & @CRLF & _
"EPON0/4:52" & @CRLF & _
"EPON0/4:53" & @CRLF & _
"EPON0/4:54"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")