# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\/.{1,}:.+|^Null|^VLAN)"
test_str = ("GigaEthernet0/5\n"
"GigaEthernet0/6\n"
"GigaEthernet0/45\n"
"GigaEthernet0/3\n"
"GigaEthernet0/1\n"
"GigaEthernet0/2\n"
"VLAN10\n"
"EPON110/111\n"
"EPON0/2\n"
"EPON0/3\n"
"EPON0/4\n"
"EPON0/1:1\n"
"EPON0/10:2\n"
"EPON0/20:3\n"
"EPON0/1:4\n"
"EPON0/1:5\n"
"EPON0/1:6\n"
"EPON0/1:7\n"
"EPON0/111:8\n"
"EPON0/1:9\n"
"EPON0/1:10\n"
"EPON0/1:11\n"
"EPON0/1:12\n"
"EPON0/1:13\n"
"EPON0/1:14\n"
"EPON0/1:15\n"
"EPON0/1:16\n"
"EPON0/1:17\n"
"EPON0/1:18\n"
"EPON0/1:19\n"
"EPON0/1:20\n"
"EPON0/1:21\n"
"EPON0/1:22\n"
"EPON0/1:23\n"
"EPON0/1:24\n"
"EPON0/1:25\n"
"EPON0/1:26\n"
"EPON0/1:27\n"
"EPON0/1:28\n"
"EPON0/1:29\n"
"EPON0/1:30\n"
"EPON0/1:31\n"
"EPON0/1:32\n"
"EPON0/1:33\n"
"EPON0/1:34\n"
"EPON0/1:35\n"
"EPON0/1:36\n"
"EPON0/1:37\n"
"EPON0/1:38\n"
"EPON0/1:39\n"
"EPON0/1:40\n"
"EPON0/1:41\n"
"EPON0/1:42\n"
"EPON0/2:1\n"
"EPON0/2:2\n"
"EPON0/2:3\n"
"EPON0/2:4\n"
"EPON0/2:5\n"
"EPON0/2:6\n"
"EPON0/2:7\n"
"EPON0/2:8\n"
"EPON0/2:9\n"
"EPON0/2:10\n"
"EPON0/2:11\n"
"EPON0/2:12\n"
"EPON0/2:13\n"
"EPON0/2:14\n"
"EPON0/2:15\n"
"EPON0/2:16\n"
"EPON0/2:17\n"
"EPON0/2:18\n"
"EPON0/2:19\n"
"EPON0/2:20\n"
"EPON0/2:21\n"
"EPON0/3:1\n"
"EPON0/3:2\n"
"EPON0/3:3\n"
"EPON0/3:4\n"
"EPON0/3:5\n"
"EPON0/3:6\n"
"EPON0/3:7\n"
"EPON0/3:8\n"
"EPON0/3:9\n"
"EPON0/3:10\n"
"EPON0/3:11\n"
"EPON0/3:12\n"
"EPON0/3:13\n"
"EPON0/3:14\n"
"EPON0/3:15\n"
"EPON0/3:16\n"
"EPON0/3:17\n"
"EPON0/3:18\n"
"EPON0/3:19\n"
"EPON0/3:20\n"
"EPON0/3:21\n"
"EPON0/3:22\n"
"EPON0/3:23\n"
"EPON0/3:24\n"
"EPON0/3:27\n"
"EPON0/3:28\n"
"EPON0/3:29\n"
"EPON0/3:64\n"
"EPON0/4:1\n"
"EPON0/4:2\n"
"EPON0/4:3\n"
"EPON0/4:4\n"
"EPON0/4:5\n"
"EPON0/4:6\n"
"EPON0/4:7\n"
"EPON0/4:8\n"
"EPON0/4:9\n"
"EPON0/4:10\n"
"EPON0/4:11\n"
"EPON0/4:12\n"
"EPON0/4:13\n"
"EPON0/4:14\n"
"EPON0/4:15\n"
"EPON0/4:16\n"
"EPON0/4:17\n"
"EPON0/4:18\n"
"EPON0/4:19\n"
"EPON0/4:20\n"
"EPON0/4:21\n"
"EPON0/4:22\n"
"EPON0/4:23\n"
"EPON0/4:24\n"
"EPON0/4:25\n"
"EPON0/4:26\n"
"EPON0/4:27\n"
"EPON0/4:28\n"
"EPON0/4:29\n"
"EPON0/4:30\n"
"EPON0/4:31\n"
"EPON0/4:32\n"
"EPON0/4:33\n"
"EPON0/4:34\n"
"EPON0/4:35\n"
"EPON0/4:36\n"
"EPON0/4:37\n"
"EPON0/4:38\n"
"EPON0/4:39\n"
"EPON0/4:40\n"
"EPON0/4:41\n"
"EPON0/4:42\n"
"EPON0/4:43\n"
"EPON0/4:44\n"
"EPON0/4:45\n"
"EPON0/4:46\n"
"EPON0/4:47\n"
"EPON0/4:48\n"
"EPON0/4:49\n"
"EPON0/4:50\n"
"EPON0/4:51\n"
"EPON0/4:52\n"
"EPON0/4:53\n"
"EPON0/4:54")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.