using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?(?:(?:www|m)\.)?twitter\.com\/\w+\/status\/\d+";
string input = @"https://twitter.com/Twitt_erDev/status/850006245121695744
http://twitter.com/Twit1243terDev/status/850006245121695744
https://www.twitter.com/Twi234_tterDev/status/850006245121695744
http://www.twitter.com/TwitterDev/status/850006245121695744
http://m.twitter.com/Tw11itterDev/status/850006245121695744
https://m.twitter.com/Tw11itterDev/status/850006245121695744
www.twitter.com/Twitt11erDev/status/850006245121695744
m.twitter.com/Tw11itterDev/status/850006245121695744
twitter.com/Twitte345_rDev/status/850006245121695744";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}