import Foundation
let pattern = #"^(?:https?:\/\/)?(?:(?:www|m)\.)?twitter\.com\/\w+\/status\/\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://twitter.com/Twitt_erDev/status/850006245121695744
http://twitter.com/Twit1243terDev/status/850006245121695744
https://www.twitter.com/Twi234_tterDev/status/850006245121695744
http://www.twitter.com/TwitterDev/status/850006245121695744
http://m.twitter.com/Tw11itterDev/status/850006245121695744
https://m.twitter.com/Tw11itterDev/status/850006245121695744
www.twitter.com/Twitt11erDev/status/850006245121695744
m.twitter.com/Tw11itterDev/status/850006245121695744
twitter.com/Twitte345_rDev/status/850006245121695744
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)