import re
regex = re.compile(r"(?:[ \t]*[a-z][)]\s*)?([^\r\n<]+(?:(?:\r?\n(?!\s*[a-z][)])|<(?!br\s*\/?>(?:\s*<br\s*\/?>)*\s*(?:\s+[a-z][)]|\s*$)))[^\r\n<]*)*)(?:<br\s*\/?>\s*)*", flags=re.MULTILINE)
test_str = ("<strong>Preencha</strong> a lacuna e assinale a alternativa correta.<br />\n"
"<br />\n"
"I - capacitação técnico-profissional: Comprovação do licitante de possuir em seu quadro permanente, na data prevista para entrega da proposta, ________________, detentor de atestado de responsabilidade técnica por execução de obra ou serviço de características semelhantes, limitadas estas exclusivamente às parcelas de maior relevância e valor significativo do objeto da licitação, vedadas as exigências de quantidades mínimas ou prazos máximos (Lei 8.666/1993 Art N° 30).<br />\n"
"<br />\n"
"a)<strong>profissional</strong> de nível superior<br />\n"
"b)profissional de nível superior ou outro devidamente reconhecido pela entidade competente<br />\n"
"c)profissional capacitado<br />\n"
"d)profissional de nível minimamente técnico<br />\n"
"e)profissional especializado no objeto da <strong>licitação</strong><br />")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")