$re = '/^\D*\d+(?:[.,]\d+)*(\D+)\d/m';
$str = 'testsfa13.4extractthis8488.9090testssffwwww';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);