re = /^\D*\d+(?:[.,]\d+)*(\D+)\d/m
str = 'testsfa13.4extractthis8488.9090testssffwwww'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end