package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<Component[ \w=\{\}>\(\)\n;?".-:]*prop`)
var str = `<Component
value="lol"
onClear={() => { onChange?.(""); }}
prop={"test"}
>
<Component
value="lol"
prop={"test"}
/>
</Component>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}