#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "is1t.*?Test(\d+).*"
Local $sString = ""213Das "is1t" 'ein' Test32" "253Das "ist" 'ein' Test332" "23Das "ist" 'ein' Test342" "237Das "is1t" 'ein' Test32" "283Das "ist" 'ein' Test312" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")