import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "is1t.*?Test(\\d+).*";
final String string = "\"213Das \"is1t\" 'ein' Test32\" \"253Das \"ist\" 'ein' Test332\" \"23Das \"ist\" 'ein' Test342\" \"237Das \"is1t\" 'ein' Test32\" \"283Das \"ist\" 'ein' Test312\" ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}