re = /^(?:\d+ )?\(?([0-9]{3})\)?[-. ]?([0-9]{3})[-. ]?([0-9]{4})$/m
str = '1 456 789 4444'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end