package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)..$`)
var str = `test01
abcd02
xyz05
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}