$re = '/(.*)..$/m';
$str = 'test01
abcd02
xyz05
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);