package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(?:a\b[^>]*>|/a>)`)
var str = `<p>Some text<a href="#">link</a></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}