$re = '/<(?:a\b[^>]*>|/a>)/';
$str = '<p>Some text<a href="#">link</a></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);