package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^.]*)(\.#+)(\..*)?$`)
var str = `bob.#
bob.#.
bob.#.exr
bob.##.mary.tif
bob.####.png
Whereas the following would not match:
bob.#string.exr
bob.string#.exr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}