$re = '/^([^.]*)(\.#+)(\..*)?$/m';
$str = 'bob.#
bob.#.
bob.#.exr
bob.##.mary.tif
bob.####.png
Whereas the following would not match:
bob.#string.exr
bob.string#.exr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);