const regex = /^(?:\d{5}|^(?=\d* \d*$).{6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{5}|^(?=\\d* \\d*$).{6})$', 'gm')
const str = `73648
3 0324
98734
98234
324234
324 343
33 345
f7364ffff8f `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}