import re
regex = re.compile(r"^(?:\d{5}|^(?=\d* \d*$).{6})$", flags=re.MULTILINE)
test_str = ("73648\n"
"3 0324\n"
" 98734\n"
"98234 \n\n"
"324234\n"
"324 343\n"
"33 345\n\n"
"f7364ffff8f ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")