using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:This is a|\G(?!\A))\h+((?=.*so it is\.)string\d+)";
string input = @"This is a string1 string2 string3 string4 string5 string6 string7 so it is.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}