re = /(?:This is a|\G(?!\A))\h+((?=.*so it is\.)string\d+)/m
str = 'This is a string1 string2 string3 string4 string5 string6 string7 so it is.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end