package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[ \t]*see also[ \t]*:?[ \t]+(.*)`)
var str = `See Also: something.m, something_else.m
See Also: something.m, something_else.m
See Also : something.m, something_else.m
see also: something.m, something_else.m
see also : something.m, something_else.m
see also something.m, something_else.m
text before makes this invalid See Also: something.m, something_else.m
See Also:something.m, something_else.m
See Als: something.m, something_else.m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}