use strict;
my $str = 'See Also: something.m, something_else.m
See Also: something.m, something_else.m
See Also : something.m, something_else.m
see also: something.m, something_else.m
see also : something.m, something_else.m
see also something.m, something_else.m
text before makes this invalid See Also: something.m, something_else.m
See Also:something.m, something_else.m
See Als: something.m, something_else.m';
my $regex = qr/^[ \t]*see also[ \t]*:?[ \t]+(.*)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}