const regex = /\b(?!(5000|2048)\b)\d+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(5000|2048)\\b)\\d+', 'g')
const str = `mylink:5000
mylink:2048
mylink:20488`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}