$re = '/\b(?!(5000|2048)\b)\d+/';
$str = 'mylink:5000
mylink:2048
mylink:20488';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);