import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{L}\\d]";
final String string = "լոռեմ իպսում դոլոռ սիթ ամեթ, նե եամ դոլոռեմ ածծոմմոդառե, վիմ ինանի պեռֆեծթո ռաթիոնիբուս ծու, պոսսե վիռիս ոպոռթեռե եխ վել. նե սուաս նոսթռուդ պեռ, ութռոքուե սալութանդի դեֆինիթիոնես ծում եթ, բլանդիթ ռեպռեհենդունթ նեծ ադ. նոսթեռ պռոբաթուս ութ վել, եա ալթեռա աեթեռնո աթոմոռում եում, նոմինավի թածիմաթես դելիծաթա ծու ուսու. սթեթ թոլլիթ \"Hi There\" 12345679";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}