$re = '/-(START(?=(?:_[^_]*){3,4}-END).*?)_+\d+(?=-END)/m';
$str = 'test-START_one_two_three_4-END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);