re = /-(START(?=(?:_[^_]*){3,4}-END).*?)_+\d+(?=-END)/m
str = 'test-START_one_two_three_4-END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end