const regex = /([a-zA-Z0-9 ]*:[a-zA-Z0-9\- :]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9 ]*:[a-zA-Z0-9\\- :]*)', 'gm')
const str = `Signature Algorithm:ecdsa-with-SHA256&Not Before:Jul 23 00:00:00 2018 GMT&Not After:Jul 19 00:00:00 2033 GMT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}