$re = '/([a-zA-Z0-9 ]*:[a-zA-Z0-9\- :]*)/m';
$str = 'Signature Algorithm:ecdsa-with-SHA256&Not Before:Jul 23 00:00:00 2018 GMT&Not After:Jul 19 00:00:00 2033 GMT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);