package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_0-9]{3,20}@gmail.com`)
var str = `test_regex@gmail.com%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}