$re = '/[a-zA-Z_0-9]{3,20}@gmail.com/m';
$str = 'test_regex@gmail.com%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);