$re = '/(^([^\[])+)(.+?(?=&|\]))?(.+?(?=\]))?/m';
$str = 'text [text1 & text2]
text [text1]
text [text2]
text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);