re = /(^([^\[])+)(.+?(?=&|\]))?(.+?(?=\]))?/m
str = 'text [text1 & text2]
text [text1]
text [text2]
text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end