$re = '/.*[^a][^b]$/m';
$str = 'jd8a
8$fb
q(c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);